Some questions about getting started with RSL10 SDK

  1. I am working with ON Semiconductor SignaKlara Development Tools Evaluation and Development Kit Version 5.2.1 now , if I install Eclipse based tools of RSL10, should I uninstall SignaKlara Development Tools? Can I combine these two tools?

  2. I had tried to use Keil ,followed all steps of guide , there still some problem as below:
    a. no keil’s project file in sample code (blinky)
    b. I add a new project, but report “RSL10_CID must be defined” while rebuild the project.
    c. What debugger device should I setup in keil’s debug option window when using the attached micoro-usb calbe to connected the SDK board?

Is there any more details to getting started?

I have sloved question 2 by manully copy the sample code, rebuild report two warning now:

C:\Keil_v5\ARM\PACK\ONSemiconductor\RSL10\3.4.2-4\source\firmware\rtt\SEGGER_RTT_ASM_ARMv7M.S(238): warning: A1313W: Missing END directive at end of file
.\RTE\Device\RSL10\sections.sct(42): warning: L6329W: Pattern *(ZI) only matches removed unused sections.

does it caused by my AMC compiler version 5.06 is build 528?

@quixote

I am working with ON Semiconductor SignaKlara Development Tools Evaluation and Development Kit Version 5.2.1 now , if I install Eclipse based tools of RSL10, should I uninstall SignaKlara Development Tools? Can I combine these two tools?

These are two independent tools. The the SignaKlara tool was developed quite a while ago. I wouldn’t expect any problems but let us know if you experience any problems.

I had tried to use Keil ,followed all steps of guide , there still some problem as below:
a. no keil’s project file in sample code (blinky)
b. I add a new project, but report “RSL10_CID must be defined” while rebuild the project.
c. What debugger device should I setup in keil’s debug option window when using the attached micoro-usb calbe to connected the SDK board?

Would you please refer to our Getting started manual " CHAPTER 4
Getting Started with Keil " for detailed steps that needed to be follow?

c. What debugger device should I setup in keil’s debug option window when using the attached micoro-usb cable to connected the SDK board?

Please see my settings below:

image

I have sloved question 2 by manually copy the sample code, rebuild report two warning now:
C:\Keil_v5\ARM\PACK\ONSemiconductor\RSL10\3.4.2-4\source\firmware\rtt\SEGGER_RTT_ASM_ARMv7M.S(238): warning: A1313W: Missing END directive at end of file
.\RTE\Device\RSL10\sections.sct(42): warning: L6329W: Pattern *(ZI) only matches removed unused sections. Does it caused by my AMC compiler version 5.06 is build 528?

This might be caused by not following step procedure in "Getting started manual CHAPTER
4.Getting Started with Keil ". I have tested blinky example in Keil and was able to debug this without any errors from CMSIS pack.

Thank you for using our community forum !