Issues with RSL10 USB Dongle and Windows 10

Hi there,

I am trying to use the RSL10 USB DONGLE (RSL10-USB001GEVK) with the Bluetooth Low energy Explorer application in Windows 10. I haven’t been successful in 3 computers. It seems that the driver is not properly installed.

After Windows installed it, I see the following on the device administrator “CP2102N USG to UART Bridge Controller” with an asterisk.

If I open the desktop application, it does not detect the COM port and it closes unexpectedly.
In my laptop it does not open at all. I think it is because I have a BLE built in the computer but no idea.

I tried downloading CP2102 drivers from the Internet but I get the same result.

Any idea what I can do?

@BLEDev
Hello,

Please look for the document RSL10 USB Dongle User Guide in your folders
…\RSL10 USB DONGLE BLE EXPLORER.

Before Using Bluetooth Low Energy Explorer

  1. Install the Bluetooth Low Energy Explorer software.
  2. Plug the RSL10 USB Dongle into a USB port. You might be prompted to install device driver software. Check
    the RSL10 USB Dongle version to determine whether it is RSL10 v1.02 or RSL10 v1.02 B.
    • Find the driver in the Driver folder where you have installed Bluetooth Low Energy Explorer. Unzip the folder corresponding to the RSL10 USB Dongle version, and install the appropriate .exe file.
  3. Open the windows Device Manager and check which com port has been assigned (see pic below).
    Now you can start Bluetooth Low Energy Explorer.

image

General:

Please let me know if you have followed these steps and if this does not help please provide USB to UART bridge image that you captured from the device manager.

Thank you @martin.bela .

I did but it seems not working.
My module is RSL10v1.02 It does not have the B in the name.

After installing the driver I still get this message:
devices

Properties:

device_2

sorry. It is in spanish but you can see it is not detected as yours.

@BLEDev

Hello,

Can you check that you have installed drivers on your computer?

Device manager:

My administrator does not have “Driver” tab. I think it is because it is not properly installed because I can see that tab on the other COM ports.

I have tried several times to install the driver you tell me and I get a good response from the installer application about it but it seems that nothing changes.

@BLEDev

Since you do not have the driver tab, your system is likely limited to your available permissions.

Would it be possible to try this on on another PC ?

@martin.bela I got it working!. I deleted everything and started over again. After installing the drivers, the pc could accepted the module. Now it works like a charm.
Thank you for your support.

3 Likes

I’m having the same problem: explorer.exe starts then exits most likely because COM port is missing.
My Drivers directory does already contain a file silabser.sys. Its Properties does not have the ‘driver’ tab hence I assume it is not a driver.
Calling CP210xVCPInstaller_x64.exe to replace it does not work although I have administrator rights.
A reason might be because Microsoft has bothered me for weeks preparing my PC for upgrade to Windows 11 (which I don’t want).
Can someone help me please !!

@lvrk
Would it be possible to look for the document RSL10 USB Dongle User Guide in your folders
…\RSL10 USB DONGLE BLE EXPLORER. and follow all the steps suggested in there?
Please scroll up and see print screens of the device if everything working properly.