.fota not generated after building the code

Hi,

I have successfully build the ble_peripheral_server_hrp_fota sample code. But ble_peripheral_server_hrp_fota.fota is not generated. Could you please suggest your opinion on this.

@reshma9464

Would you please provide print _ screen of your Debug window similar to this:

Example: ble_peripheral_server_hrp

The same is for ble_peripheral_server_hrp_sleep

It might help to clear or refresh your workspace from older projects entirely.

Thank you for using our community forum.

@martin.bela

please find the below attachment for the debug window of the mentioned sample code.fota|690x202

@reshma9464 Would you please re-attach your project files cause I am not able to download them ? Alternatively, please use my e mail : onhelp@onsemi.com and copy the subject : .fota not generated after building the code
Thank you,

@martin.bela

Please find the attachment. I have mailed the same to the mentioned e mail.

@reshma9464 . Please try to clean up your workspace, from any other previous projects and their files so the only project in your workspace will be ble_peripheral_server_hrp_fota.

Another option is to create new workspace and build the new project. After successful build, you should see ble_peripheral_server_hrp_fota.fota file as below:

image

Thank you for using our community forum !

@martin.bela

I tried as you suggested. Still am not getting. Could you please suggest any other options.

Hi @reshma9464

What do you see in the build console window after you build the application?
Maybe you are missing python or some other dependency.

You should have 3 lines near the end related to the FOTA post-build step.
Something like this. No error messages.

make --no-print-directory post-build
Invoking: Cross ARM GNU Create FOTA Image
arm-none-eabi-objcopy -O binary "smartshot_demo_cam.elf" "smartshot_demo_cam.bin" && "C:/Users/user/Workspaces/ON_IDE_35/test/smartshot_demo_cam/RTE/Device/RSL10/mkfotaimg.py" -o "smartshot_demo_cam.fota" "C:/Users/user/Workspaces/ON_IDE_35/test/smartshot_demo_cam/RTE/Device/RSL10/fota.bin" "smartshot_demo_cam.bin"

The build engine does not seem to care if the post build step fails or not and always shows that build finished without errors.

Best regards,
Lukas

Hi,

I have tried again and .fota is generated now. I tried loading FOTA image through UART with the following steps:

1.Initially loaded bootloader with bootloader.hex file.
2.Then pressed Reset button followed with DIO5.
3.Released reset initially then DIO5. LED is continuosly ON now
4.Given the command- python updater.py COM4 ble_peripheral_server_fota.fota.

But I am getting Assertion error as no data received as shown below. could you please suggest any solution.
C:\Users\zoyar\onsemi_fota\bootloader\scripts>python updater.py COM4 ble_peripheral_server_hrp_fota.fota
Image : PSHRP ver=2.4.1 / FOTA ver=2.4.1
AssertionError: no data received

Hello,
I have same problem. Did you solve this problem?
If so , can you explain it to me?

Thank you