F143-MINI-2-GEVK: AX8052F143 Mini Development Kit | UART Baud Rate

I am trying to change the baud rate of the F143-MINI-2-GEVK: AX8052F143 Mini Development Kit using uart_timer0_baud and uart_timer1_baud functions, where I am setting the baud rate = 9600 instead of 115200. But after deploying the code, I am getting the same Baud rate as earlier which is 115200. Can anyone tell what mistake I am doing.

Hello.
Seems like your uart_timer0_baud(CLKSRC_SYSCLK, 9600, 20000000UL); gets overwritten somewhere else during execution.
Note that the code does interface with the UART in multiple places and it may default back to 115200. I can suggest you to do a CTRL-F of “115200” across your code and see where you may have missed a function.

1 Like

Thank you, Georgi.
It worked.

In the current configuration, Transmitter only transmits pre-programmed data (entered in the framing panel). I want to transmit data through a PC using UART. Is there any standard way of doing it?

I see that
const uint8_t __code demo_packet[] = { 0x00, 0x22, 0x22, 0x22, 0x22, 0x22 };
This is where the packet data is stored. Now I want to transmit data through PC. I have enabled UART0 for transmitter in transmit on-demand mode. But I don’t know where the UART data is getting stored.