Cannot debug a BLE example

Hello everyone,

I’m trying to build and debug the example “ble_peripheral_server_hrp_fota_sleep” on the evaluation board EVBUM2529 featuring a RSL10.

I can succesfully build this project (without any modification) but when I launch the debug configuration (created following the getting started guide), it says:

Break at address “0x106b76” with no debug information available, or outside of program code.

In the other hand, I tried the same thing with peripheral_server_sleep example and I’m able to build and debug the project without any issue.

What am I missing?

Thanks for your help

@arthur

Please refer to our community forum thread at:

FOTA configuration: how to debug the user app part with jLink RTT in FOTA mode?

Thank you for using our community forum!

Hello Martin,

Thanks for your feedback, following these instructions, I can now debug the project.

3 Likes

Hi @martin.bela,

I have the same issue as Arthur but the approach described in the linked comment post does not solve the issue for me.
I am using the new onsemi IDE and the example project ble_peripheral_service_hrp_fota_sleep without changes. Debugging ble_peripheral_service_hrp_fota works fine for me.

Please see the issue screenshot below.

Is there anything else that I should check?

Thank you!

@thellmuth

Do you have . fota file in \ bootloader\scripts as you can see on the screen below?

image

and was upload successful? You should see something like :

1 Like

@martin.bela
I did a completely clean setup and went through every step again and it worked.
Thanks a lot.
I am now able to debug the fota as well as the fota sleep example on the RSL10 Eval Board.