B-IDK Flashing Error:Break at address "0xdeadbeee" with no debug information available, or outside of program code

Until yesterday, I was able to flash to B-IDK via USB using ON IDE, but today I can’t flash to B-IDK from ON IDE.

In the ON IDE, “Break at address” 0xdeadbeee “with no debug information available, or outside of program code.” Is displayed, and when I open Diassembly, I get a lot of error messages.

How can I use ON IDE to flash to B-IDK via USB again?

Would it be possible to follow up instructions in RSL10 documentation package , getting started and import the Simple GPIO I/O sample code (affectionately known as blinky) ?

No. I tried flashing some sample projects and got the same error.
Even if I reset the board, it doesn’t fix.

The reported behavior sounds like it might be application specific.
Is the behavior reproducible with any other application?
Would you get Simple GPIO I/O sample code (affectionately known as blinky) running without this error?

What do you mean by other applications, for example? I only have one B-IDK.
I got the same error with Simple GPIO I/O sample code.

We do have some advice regarding what we do believe is a likely cause of this issue. This is often caused by a program in Flash causing an immediate Hardfault which prevents the JLink from communicating properly. The solution is often to use a RAM based firmware that erases the entire main Flash area so it can be reprogrammed through JLink properly. We came up with the following firmware and steps that you can try and follow:

  1. Import and build the project firmware that we have shared below (blinky_erase_flash.zip)
  2. Follow the steps outlined in this forum post to generate a RAM debugging setup for the firmware
  3. Rebuild the project so the debug .hex makes use of the new RAM placement
  4. Using the RSL10 IDE, download and run/debug the firmware on the device
  5. If the LED starts Blinking (DIO6 in this sample to align with SiP and QFN, change this in app.h if using a different EVB) the Flash Erase was successful
  6. Attempt to load your own firmware into Flash again and check for the ‘0xdeadbeee’ error

blinky_flash_erase.zip (52.9 KB)

Thank you for your support. However, I cannot resolve this error.
I attach console log information when this error was happened.
Console_log.txt (14.7 キロバイト)

Do you have another B -IDK to test whether the same error " WARNING: Failed to read memory @ address 0xDEADBEEE " will appear?

Would you please try to short DIO12 to GND and power reset and then load the hex file ?

I don’t have any other B-IDK… I have only one B-IDK.
I performed the step of shorting DIO12 to GND and power reset, but this error occurred.

Based on your log file, the chip does not have response for jlink command “halt”.

How about using our standalone flashloader program to do erase when DIO12 short to GND?

image

Sometimes the firmware in RSL10 cannot be successfully re-flashed, due to the
application going into Sleep Mode or resetting continuously (either by design
or due to a programming error). To circumvent this scenario, a software
recovery mode using DIO12 can be implemented with the following steps:

  1. Connect DIO12 to ground.
  2. Press the RESET button (this restarts the application, which will
    pause at the start of its initialization routine).
  3. Re-flash RSL10. After successful re-flashing, disconnect DIO12 from
    ground, and press the RESET button so that the application will work
    properly.

It looks like the Erasing process is complete with your Flash Loader, but I get an error in the Programming process.
I attach the log information.
Flashloader_log.txt (1.2 キロバイト)

The version of Flash Loader is Version 2.1.164.
FlashLoader_Version

Hello satogata-s

Would you please try to load blinky.hex example via Standalone flashloader?

blinky.hex (4.3 KB)

Hi @martin.bela

Thank you so much for your support.
I was able to successfully pass the loading of blinky.hex.
After that, I was able to safely flash other projects from ON IDE.
Flashloader_log-blinky.txt (1.3 キロバイト)